Back to overview
Resolved
Elevated platform errors
Jul 16, 2026 at 8:26am UTC
Affected services
Evidence Studio Application
Published Reports
Resolved
Jul 16, 2026 at 10:44am UTC
The root cause of the issue was an outage with a provider which is now resolved
Affected services
Created
Jul 16, 2026 at 8:26am UTC
Some users may not be able to log in or receive verification code emails
Affected services