Back to overview
Downtime
Query Engine is down
Mar 21, 2026 at 10:52am UTC
Affected services
Query Engine
Resolved
Mar 21, 2026 at 2:17pm UTC
We have applied a fix. The query engine is now operating as normal.
We are continuing to monitor as services recover.
Affected services
Updated
Mar 21, 2026 at 2:14pm UTC
We have identified the cause of the outage. We are working on a fix.
Affected services
Created
Mar 21, 2026 at 10:52am UTC
The Evidence Query Engine is down. We are investigating
Affected services