Back to overview
Resolved

Elevated issues with Evidence Studio

Feb 16, 2026 at 2:58pm UTC
Affected services
Evidence Studio Application

Resolved
Feb 16, 2026 at 2:58pm UTC

Some users have reported errors editing projects using Evidence Studio. We are investigating.