Back to overview
Resolved
Elevated Authentication Errors
Oct 20, 2025 at 9:11pm UTC
Affected services
Evidence Studio Application
Resolved
Oct 20, 2025 at 9:11pm UTC
Our authentication provider is undergoing an outage leading to increased errors when authenticating into Evidence Studio.
Affected services