Back to overview
Downtime
Google SSO is experiencing issues
Sep 18 at 06:20am HDT
Affected services
Console
Resolved
Sep 18 at 10:01am HDT
Google SSO is working as expected again.
Affected services
Created
Sep 18 at 06:20am HDT
Google SSO is experiencing issues. If you use Google SSO to login, you may not be able to access Evidence Studio right now.
As a workaround, you can sign in with the same email using a one time passcode via email.
Affected services