Back to overview
Resolved

Response Times are degraded

Aug 21, 2025 at 6:41pm UTC
Affected services
Evidence Studio Application

Resolved
Aug 21, 2025 at 8:19pm UTC

Issues with our auth provider have been resolved. Latency is now back to normal.

We are continuing to monitor for the situation.

Created
Aug 21, 2025 at 6:41pm UTC

Our auth provider, WorkOS has an outage.

During this time, responses are slower than usual, causing navigating between pages in Evidence Studio to be slow

WorkOS Status: https://status.workos.com